Firefox 16.0.2 Installed

Firefox version 16.0.2 is now installed in TarHeel Linux repository for both x86_64 and i686, TarHeel Linux 5 and TarHeel Linux 6.

If you machine is equipped with NVidia card and NVidia driver from NVidia is installed, Firefox version 16 will cause X11 to crash in TarHeel Linux 5.  The fix is to use the NVidia driver from Elrepo instead.  Login  as root and get Elrepo YUM setup.

yum install elrepo-release

Then, install NVidia driver from Elrepo.

yum install kmod-nvidia

Reboot the machine and your machine will be using the NVidia driver from Elrepo.

Another advantage in using NVidia driver from Elrepo is that you will not have to update the driver manually when there is a kernel update.